Launching SpongeVan with Java 9


#1

Sorry if this is a double post however I only found one semi-old thread on Java 9 and it wasn’t really related. Unsure if this is a bug or just a glitch. It appears the java-9 repo in an older Ubuntu doesn’t play nice with the latest SpongeVan.

Exception in thread “main” java.lang.RuntimeException: We have detected that you are JRE version 9-internal, which is out of date!
In order to run Sponge, you must be running JRE version 1.8.0_20 (or above).
Previous builds of JRE version 1.8 will not work with Sponge.

openjdk version "9-internal"
OpenJDK Runtime Environment (build 9-internal+0-2016-04-14-195246.buildd.src)


#2

It happened to me too on windows with Java 9. I think sponge got the full version of java. And made sure the java update was past something like update 25. And dont check the actual version of java 8


#3

Java 9 introduced breaking changes to classloaders. Mc server, forge are affected as well and needs to be updated first


#4

Relevant issue with explanation: https://github.com/SpongePowered/SpongeVanilla/issues/355