Server won't start!


#1

So, I’m trying to setup an FTB Beyond server with SpongeForge so I can use plugins, but the server always seems to crash before I can even start the world. I don’t know how to fix this and I’ve been trying for the past couple hours removing mods and changing versions. Please help!

Here is the log,
https://pastebin.com/hh1acQxP


#2

The error you have there: net.minecraftforge.fml.common.MissingModsException: Mod bitdrawers (Drawers & Bits) requires [Forge@[12.18.3.2221,)]

Is stating that the version of forge you have is before version 12.18.3.2221

The forge version you are using is Forge 12.18.3.2202

The way to read the mod version requirements is [Forge@[12.18.3.2221,)] is an [array] of mod requirements. Drawers and bits requires Forge@versionRange.

The versionRange required is [12.18.3.2221,)

This follows mathematic ranges. https://en.wikipedia.org/wiki/Bracket_(mathematics)#Intervals

e.g. The notation [a,c) is used to indicate an interval from a to c that is inclusive of a but exclusive of c.

So that mod needs 12.18.3.2221 or higher version of forge.

I can’t speak for errors you havn’t shown, but generally I would just be running the latest forge for 1.10 with the latest spongeForge for 1.10 with the latest version of the mod pack you are using and go from there.


#3

Okay I think I understand. I’m using the latest release of SpongeForge atm so does that mean its not compatible? Or am I missing something?

Edit: I’m actually really dumb, I finally get what you’re saying. Thank you so very much!