:shipit: SeriousVote 4.8.4 ―Your one stop Votifier Listener API 5/6/7


I got this error what do I need to do or is it nothing?


please use the latest version
bleeding E


Hi, was setting up this plugin to work with Nuvotifier but seem to be having issues. I kept getting "did you break the config? :(" messages but when I thought I finally fixed it I now get "Error occurred while executing command:2"

Any help would be great, still getting use to editing configs again (Been years) So if I made any dumb mistakes sorry xD

Server details: Pixelmon server, running latest sponge, 1.10.2 version, latest forge, latest sponge API, most/all plugins are up to date. Though I did notice that you just released 3.2 for seriousvote so will update that while I send this message.

Screenshot of error message in console:



under random rewards if you don't want any than set the number to 0, it's missing the third "" so it's gonna throw an error if you're trying to use it.In the upcoming official build I'll be adding a check for that, so it will tell you it is messed up before trying to execute them.
random-rewards-number: 0


Hey guys there is a new build bleeding F which fixes some problems with the broadcasting system after changing it to be more encapsulated.


Hmmm there's an issue with a player named SAVELY_IS_SAVAGE's votes not getting rewarded, and it's just him only so far. My initial assumption is that his name is too long?


I don't think that would be it, does the console throw any errors? Also does his name have that apostrophe or did you add it in?


@curscascis When someone vote, then the text in minecraft says Name just voted! He got No Random Rewards ! but they just get like a golden apple. is there something wrong in the config?


no apostrophe. What would be the issue then? I've yet to check the errors. Been busy, just saw his report. I'll update you when I have more info


This was fixed in bleeding F, please update.


Thanks, if he's not getting a reward than his reward might be going into offline mode, so let me know.


Hi, was able to fix my earlier issue but now I have another one xD I can't seem to get votes to come through/work on any of the bungee servers or lobby, so any ideas would be great

NuVotifier config:

SeriousVote config:

Screenshot of error message in console:

To my knowledge all needed ports are open, the voting websites themselves detect and say the server are online and that voting is enabled/working, I mentioned earlier the server is a bungeecord server. All servers + the bungee have Nuvotifier and are all running the same config and the listening key being used is the Hub worlds, Hoping that its just a dumb mistake on my side that can easily be fixed, but willing to try any troubleshooting tips thrown my way, thanks!


NV needs to be installed as a bungee plugin, and you need to give each one a different port as well. One on bungee the other ones on the receiving servers each with their own port.


Hmm, haven't been able to get database working. Config is the exact same as before, but have "enabled: true" under milestones.

It's been like this since bleeding D. When I do /svreload it gives me:
[00:19:34] [Server thread/INFO] [seriousvote]: Milestones Disabled


Hmm, think offline votes isnt working too well with project inventories. Any way you could also delay when it gives the rewards for offline votes to try to solve that?


Could we add our own text with /vote? I already tried and it gives me "Malformed URL. Contact Administrator"



Currently it only supports adding links.


Been using this for a few days now. Milestones could use some work. I'd like to request an option to add milestones per x Votes. Not per X Days of Voting.

Thanks for your time on this project. It's coming along very nicely


I was able to fix the issue kinda, gave each one a different port and blah but now I get this in the bungeecord console:

Any ideas on that? Thanks


Looks like you don't have the proper file permissions. How are you hosting it?