:shipit: SeriousVote 4.8.4 ―Your one stop Votifier Listener API 5/6/7


Thanks for the info. Could you please submit an issue on the github.


How would the plugin know if a player has voted a week in a row?


That’s what the database is for.


It has to be specifically x days in a row right? So if I got my 30-days in a row reward and vote on the 31th day, it won’t count that as another 30-day reward?

Also, what if they vote 29 days in a row, forgot to vote on the 30th day, then vote on the 31th day; what will happen?


every 7 days, every 30 days, and every 365 days for the “dailies”
If they miss a day it restarts the counter, that’s the purpose of it being daily.
On day 31 it will just be 31 days of voting but no extra reward, the next reward would most likely be a weekly reward.


Ah thanks for clearing it up! :grinning:


I’m getting this error everytime I type /vote. It still sends the message, but just has an additional error at the end. It didn’t do this before until I added the dailies recently. http://puu.sh/yAFip/2e98f03e56.png

This is my config https://pastebin.com/KyQnRcbb


@curscascis Same config, getting more bug reports from players. It has only been the 7th day since we started doing dailies and someone got a yearly reward message already, which shouldn’t be possible.

Offline voting also kills your vote streak

Did you also notice that it says “You have 6 more until next dailies reward” on the first image, and 5 on the 2nd image when they needed 7 and 6 respectively? The number is 1-off. Would be great that we can customize the dailies message as well.


:shipit: Update SeriousVote 4.8―Your one stop Votifier Listener API 5/6/7

Updated to fix issues with the dailies a few other couple issues including database timeout and some possible error messages.


SeriousVote 4.8.3 Update :ribbon:

-Fixed Database issues and corrected connection pool timeouts
-Fixed missing space in message
-Fixed NPE while processing votes for non-existent players

:octocat: Download 4.8.3 - Latest Stable


SeriousVote 4.8.4 Update :ribbon:

  • New svversion command

  • New svdebug command

  • Updates and fixes

  • Updated config descriptions

  • 3 New Config Options

    •     #Set to true if you would like a message to be shown When the player votes even if they're offline.
           broadcast-offline: false
           #// Message to be shown
           broadcast-message-offline: "&4{player} &eJust Voted while offline! If you like it here show your support! &6run &5/vote"
           #//Set to true if you want commands to run even if the player is not online. No offline vote information will be stored
           bypass-offline: false   
  • These will allow for some added flexibility for some users.

  • Fixed possibly incorrect values being shown to the user when counting vote streaks.

:octocat: Download 4.8.4 - Latest Stable


I get the following error:

Error occurred while executing command ‘vote’ for source EntityPlayerMP[‘username’/661, l=‘world’, x=-5935.30, y=78.66, z=-7748.56]: null

when someone tries to use /vote.
Also, I get:

[seriousvote]: There was an error while reloading your configs
[seriousvote]: java.io.IOException: configurate.typesafe.config.ConfigException$Parse: Reader: 1: Expecting close brace } or a comma, got end of file
Could not reload properly :frowning: did you break your config?

when using the /svreload command.

I’ve looked over the config multiple times, and I cant find any errors, even comparing it to the origional config. I have pasted my config below.



you are missing an end quote on line 219


I had checked it line by line, at least three times. Thank you for spotting that.

Edit: So, that didn’t fix it. It is still giving the same error with that end quote in place. New pastebin: https://pastebin.com/tyMAWZ3d

the default config worked fine, and I other than that one end quote, i dont know what went wrong.


I fixed it… and the fix was, well, wierd.

I turned on “Show All Characters” in notepad++, and compared the original file to my file. At the end of every line in the original config were the markings (cr)(lf) meaning carraige return and line feed. on my config, there was only (cr). Somehow the line feed marking got removed. I did a replace (which was not easy to figure out how to do), and now it is loading properly and works fine. But may I just say… UGH!

So if anyone has this issue in the future, it may be that somehow the formatting of the file i got broked like mine did. in that case, this will help fix it. maybe.

Edit: Also learned that the give command no longer works with numerical item ids like i’m used to from 1.7.10, so if anyone has issues getting the give command to work, make sure you look up how the string ids work. its a bit different than you may be used to.


use this option in Notepad++ because windows.


i get this error everytime i vote
25.06 13:05:09 [Server] Sponge The Scheduler tried to run the task nuvotifier-A-85 owned by Plugin{id=nuvotifier, name=NuVotifier, version=2.3.5, source=./mods/serious-nuvotifier-universal-2.3.5.jar}, but an error occured.
25.06 13:05:09 [Server] INFO java.lang.NoClassDefFoundError: org/spongepowered/api/event/cause/NamedCause
25.06 13:05:09 [Server] INFO at com.vexsoftware.votifier.sponge.VotifierPlugin$3.run(VotifierPlugin.java:382) ~[VotifierPlugin$3.class:?]
25.06 13:05:09 [Server] INFO at org.spongepowered.api.scheduler.Task$Builder.lambda$execute$0(Task.java:139) ~[Task$Builder.class:1.12.2-2705-7.1.0-BETA-3171]
25.06 13:05:09 [Server] INFO at org.spongepowered.common.scheduler.SchedulerBase.lambda$startTask$0(SchedulerBase.java:186) ~[SchedulerBase.class:1.12.2-2705-7.1.0-BETA-3171]
25.06 13:05:09 [Server] INFO at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_77]
25.06 13:05:09 [Server] INFO at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_77]
25.06 13:05:09 [Server] INFO at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_77]
25.06 13:05:09 [Server] INFO at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_77]
25.06 13:05:09 [Server] INFO at java.lang.Thread.run(Thread.java:745) [?:1.8.0_77]


You are using the wrong version of nuvotifier: Use Serious nuvotifier for API 7 as it says in the main post.


Hey, I was wondering if you could help me with something. Do we need both ServiousVote and Serious-NuVotifier API-7 (Unofficial) running on a server, or just the Nuvotifier API 7?? Thanks for the plugin!


If there’s an official API 7 that works you can just use that. If there isn’t just use serious nuvotifier. Only use one or the other. Last I checked there wasn’t a working api7 one. But that was a while ago.