🏆 AdventureMMO [v2.0.7] [API 4/5/6]


#102

Nothing has changed.


#103

Ill do some testing, i will respond back when i know more.


#104

Since forge 2098, sponge has made some changes in the particle effects. This will cause errors with the plugin. I you want to keep using the plugin, use a version older than 2098. I will make a new version for soon, but right now, i cant seem to be able to import these changes to my workspace.


#105

Is there any way to remove a certain loot from fishing? If not will there be one in future? I couldn't find one in config and would rather not have players getting skulls from fishing treasure.
love the plugin though :slight_smile:


#106

I will add this in a future update.


#107

Had to not use this plugin for now. It has a pretty serious inventory glitch. A few of my users had their inventories suddenly stop responding. They couldn't movie their items to chest or even to another spot in their inventories. So I shut the server down to find what caused it and removed MMO. When I did that all inventories work again but then those users logged back their entire inventory was gone! And could not be recovered by reinstalling the plugin. I look forward to this plugin when it's more stable, but for now its too risky to use. Keep up the good work


#108

Do you have any idea when this issue happens?


#109

No sorry. no errors where generated in the console and I'm sure what those players where doing when it occurred. Could have to do with being in a protected claim or coming out of a pokemon battle since we run pixelmon. those are the only two things I think they all had in common


#110

The only time my plugin deals with inventories is when repairing items, other than that, i doesnt touch them. So could it be that?


#111

Possibly, I think one was trying to repair armor in a his protected claim. Like I said I didn't really ask what they where all doing at the time just focused on trying to save their stuff and figure out what plugin caused it


#112

Okey thanks, i will look into it.


#113

@Mr_Daniel12321 i have the same problem, what describes @Deathwhitch
There were other players, but today I have. But to identify the cause I couldn't. I can't say with certainty that the guilty MMO-v1.6.0-1.10.2.jar The problem appears and disappears by itself. I'm more suspicious of nucleus @dualspiral. In the logs there is nothing suspicious there.

Plugins
ChangeSkin.jar
EconomyLite-5.0.0-2.2.6.jar
edifice-1.1.0.jar
FlexibleLogin.jar
FoxCore-0.9.5-api5-server.jar
FoxGuard-0.19.3-dev-api5.jar
Graveyards-v2.1.2.jar
HISYS-5.0.0-1.1.0.jar
holograms-v1.1.3.jar
ipregister-0.0.3.jar
JobsLite-5.0.0-1.6.3.jar
MightyLoot-2.1.jar
MineReset-1.0.6.jar
MMO-v1.6.0-1.10.2.jar
musicbox-0.41.jar
noteblockapi-2.1.jar
NoXray.jar
Nucleus-0.12.1-S5-1.10.2-plugin.jar
oredetector-1.0.jar
permanenteffects-5.0.0-0.2.0.jar
PermissionsEx-Sponge.jar
PoreRT-1.0.0-SNAPSHOT.jar
spongeforge-1.10.2-2098-5.1.0-BETA-1814.jar
TimTheEnchanter.jar
treepers-5.1.3.jar
WinterWonderland-5.0.0-v1.2.1.jar
worldedit-sponge-mc1.10.2-6.1.4-SNAPSHOT-dist.jar

#114

Can you ask whoever it happened to if they were using the repair skill around the time of it happening?


#115

If you mean the iron block, it was not used.


#116

Then i doubt it was my plugin, it doesnt really touch players.


#117

Only time will tell. If @Deathwhitch problems arise, it is not exactly your plugin :slight_smile:


#118

@ziceptor

If you can either explain to me why you think it's Nucleus, or you get logs that have Nucleus in them, or you can come up with solid steps to reproduce this, then I'll certainly look into it. If you do - put it on the Nucleus thread, not here. However, I'm not sure it's me either.


#119

@dualspiral No doubt will do so. Do not take on your account :slight_smile:


#120

i use nucleus but haven't had the issue since i stopped using mmo. didn't have it before mmo either. if it happens again without mmo installed I'll make a post there


#121

Would appreciate it, thanks