VoteRight - Sponge's First Votifier Listener [Discontinued]


#241

Using VR 1.1.3 and SA 1.7.3:


#242

Oh the irony! I introduce a system for debugging and it crashes... I did test it but I guess I didn't catch whatever error this is. I'll look into it.

Edit:
I'm going somewhere where I don't have internet acess for the entire day, so I won't be able to post whatever fixes I make until around 5:00 PM (EST)


#243

Rush rush rush! Posting this right before I run out the door, maybe it'll work, maybe not. Tested once, probably didn't catch everything. :slight_smile:
https://dl.bintray.com/meguy26/Main/com/gmail/socraticphoenix/sponge/StarAPI/1.7.4/


#244

Thanks for the update :smiley: No need to rush as I can't test it myself atm XD will do as soon as I can though. What was causing it before?


#245

I think it was just the order in which I was loading the configs, because 1 config has to be loaded first or everything explodes.


#246

Can you have a look at this? http://www.miragecraft.xyz/forum/page/1/m/18176672/viewthread/27606948-bug-voting

Players are experiencing not getting rewards sometimes. All comments so far are from trusted players.


#247

Do the players vote online or offline?
Edit: And does /vr sim ever fail like this? (From my tests, neither of these things occur, but I usually only test through the sim command, as I have a local server and stuffs)


#248

They vote online. Offline voting is disabled atm.

/vr sim always works for me. But I do get other reports from normal players not getting all their rewards


#249

Hmm.
The thing is, /vr sim is the exact same as voting from a site, from VoteRight's perspective. There very well could be a bug in VoteRight, but if /vr sim works 'perfectly' and normal voting doesn't, it has something to do with the vote being sent to the server, not VoteRight. I do, however, believe that's unlikely, and that something else is going on. Assuming you have the new star version, could I have a debug .zip file?

Also, my enjin account is meguy26, so the mysterious 1-post trainer asking questions on that thread is me. :slight_smile:


#250

Figured lol. I'll test more of /vr sim when I get home. Maybe this could be related to quakthorn's issue above. I'm still not sure what causes this because I'm positive this never happened when I use simplevotifierlistener (an alternate listener plugin)


#251

Yeah, I agree. I assume it isn't votifier, buy rather my plugin, but as of yet I have been unable reproduce the behavior. I even logged onto MirageCraft and voted a bunch, but they all went through. Hopefully some magical coincidence will shed light on the situation... The worst part about this kind of bug is the entropic nature of it, it's almost random, which makes very little sense. Regardless, I'll keep looking over my code and trying to figure out possible sources of this problem.


#252

Having an issue with the plugin also. Have experienced the issue Snowblitz was reporting, too. Anyways, the issue we are having is the plugin, or more specifically, star API, crashing on server startup. Server still starts up fine but neither star API or voteright are loading. While we have found a workaround for this issue (Deleting the entire star API config and letting StarAPI generate a new config fixes the issue, temporarily) it is still annoying to fix nearly every time we restart the server.

Running:
forge1890
spongeforge1500
Voteright v1.1.4
StarAPI v1.7.4
NuVotifier v2.3.2.2-SPONGE4x

I can get some console logs for you, but it will take me a while to compile them.


#253

Post up the errors or else we can't really see what to fix xD


#254

I'll see what I can do. Having issues replicating the issue to generate a crash report. The crash isn't appearing in any of my old logs or crash reports, so I'll post it as soon as I can get one in a fresh log.


#255

Got it:

Again, deleting the folder "com.gmail.socraticphoenix.sponge.star" in the configs fixes the bug, at least temporarily. Not sure what else is going on.


#256

Working on it.. reflection is weird

Edit:
@Halornek should be fixed:
https://dl.bintray.com/meguy26/Main/com/gmail/socraticphoenix/sponge/StarAPI/1.7.7/


#257

Thanks. Give me about 10 minutes and I'll see if this works.


#258

Problem seems to be fixed from my first tests. Can't seem to replicate the issue.


#259

05.07 12:01:01 [Server] Server thread/ERROR [FML]: Detected an attempt by a mod org.spongepowered.mod.plugin.SpongeModPluginContainer@435ae31d to perform game activity during mod construction. This is a serious programming error.
05.07 12:01:01 [Server] Server thread/ERROR [FML]: Detected an attempt by a mod org.spongepowered.mod.plugin.SpongeModPluginContainer@435ae31d to perform game activity during mod construction. This is a serious programming error
05.07 12:01:01 [Server] Server thread/INFO [VoteRight]: ------------------------------
05.07 12:01:01 [Server] Server thread/INFO [VoteRight]: description= A votifier listener for Sponge
05.07 12:01:01 [Server] Server thread/INFO [VoteRight]: author(s)= Socratic_Phoenix
05.07 12:01:01 [Server] Server thread/INFO [VoteRight]: id= com.gmail.socraticphoenix.sponge.voteright
05.07 12:01:01 [Server] Server thread/INFO [VoteRight]: version= 1.1.4
05.07 12:01:01 [Server] Server thread/INFO [VoteRight]: name= VoteRight
05.07 12:01:01 [Server] Server thread/INFO [VoteRight]: --- StarPlugin Constructed ---
05.07 12:01:00 [Server] Server thread/INFO [StarAPI]: ------------------------------

The error comes after VR, I'm not sure if it's actually VR or another plugin.


#260

That's just sponge yelling about the way Star is coded, no errors from it